systemd-serialgetty.bbappend 1.43 KB
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"

SRC_URI_append_smarcimx8mm2g = " \
	file://disable-serialgetty.sh \
	file://disable-serialgetty.service \
"
FILES_${PN}_append_smarcimx8mm2g = " \ 
        /lib/systemd/system/* \
        /etc/systemd/system/* \
"

do_install_append_smarcimx8mm2g() {
	install -d ${D}${systemd_unitdir}/system
	install -d ${D}${sysconfdir}/systemd/system/sysinit.target.wants
	install -m 0644 ${WORKDIR}/disable-serialgetty.service ${D}${systemd_unitdir}/system
	install -m 0755 ${WORKDIR}/disable-serialgetty.sh ${D}${systemd_unitdir}/system
	
	ln -sf ${systemd_unitdir}/system/disable-serialgetty.service \
		${D}${sysconfdir}/systemd/system/sysinit.target.wants/disable-serialgetty.service
}

SRC_URI_append_smarcimx8mm4g = " \
        file://disable-serialgetty.sh \
        file://disable-serialgetty.service \
"
FILES_${PN}_append_smarcimx8mm4g = " \
        /lib/systemd/system/* \
        /etc/systemd/system/* \
"

do_install_append_smarcimx8mm4g() {
        install -d ${D}${systemd_unitdir}/system
        install -d ${D}${sysconfdir}/systemd/system/sysinit.target.wants
        install -m 0644 ${WORKDIR}/disable-serialgetty.service ${D}${systemd_unitdir}/system
        install -m 0755 ${WORKDIR}/disable-serialgetty.sh ${D}${systemd_unitdir}/system

        ln -sf ${systemd_unitdir}/system/disable-serialgetty.service \
                ${D}${sysconfdir}/systemd/system/sysinit.target.wants/disable-serialgetty.service
}