base-files_3.0.14.bbappend 501 Bytes
# look for files in this layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"

PR_append = "smarc1"

BASEFILESISSUEINSTALL = "do_install_hostname_issue"

do_install_hostname_issue() {
	# change the default hostname
	echo smarct335x > ${D}${sysconfdir}/hostname

	# create /etc/issue that shows whether we are building
	# standard eca or bleeding version
	echo "${DISTRO_NAME} (${DISTRO})" > ${D}${sysconfdir}/issue
	echo "${DISTRO_NAME} ${DISTRO_VERSION}" > ${D}${sysconfdir}/issue.net
}