nodejs_0.8.14.bb 1.17 KB
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT & BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"

# Recipe rewritten (based on recipe for node v. 6) by Grzegorz Sikorski & Tomasz Rojek, Camlin Technologies, Ltd.

SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"

SRC_URI[md5sum] = "284fd2c7578064c339d9cf6a3a475ac7"
SRC_URI[sha256sum] = "e5ce2aadb4df3ea4ca7a021106ffe09d286474476454038e9ed0135eac18e6d0"

S = "${WORKDIR}/node-v${PV}"

# v8 errors out if you have set CCACHE
CCACHE = ""

do_configure () {
  export LD="${CXX}"
  ./configure --prefix=${prefix} --without-snapshot --shared-openssl --shared-openssl-includes=${STAGING_INCDIR} --shared-openssl-libpath=${STAGING_LIBDIR}
}

do_compile () {
  oe_runmake BUILDTYPE=Release
}

do_install () {
  DESTDIR=${D} oe_runmake install
}

DEPENDS = "openssl"

RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient openssl"
RDEPENDS_${PN}_virtclass-native = "curl-native python-native"

FILES_${PN} = "${bindir}/node ${libdir}/node/wafadmin ${libdir}/node_modules"

BBCLASSEXTEND = "native"