nodejs_0.10.4.bb 1.22 KB
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT & BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1b19aee7bf088151c559f3ec9f830b44"

# Recipe rewritten (based on recipe for node v. 6) by Grzegorz Sikorski & Tomasz Rojek, Camlin Technologies, Ltd.

SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"

SRC_URI[md5sum] = "a4554450864af89c4420c54349b62295"
SRC_URI[sha256sum] = "1c960d2822447a9e4f7c46b832ff05e86743033c6643d644975af1cbf6a44fb8"

S = "${WORKDIR}/node-v${PV}"

PR = "r5"

# v8 errors out if you have set CCACHE
CCACHE = ""

do_configure () {
  export LD="${CXX}"
  ./configure --prefix=${prefix} --without-snapshot --shared-openssl --shared-openssl-includes=${STAGING_INCDIR} --shared-openssl-libpath=${STAGING_LIBDIR}
}

do_compile () {
  oe_runmake BUILDTYPE=Release
}

do_install () {
  DESTDIR=${D} oe_runmake install
}

DEPENDS = "openssl"

RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient openssl"
RDEPENDS_${PN}_virtclass-native = "curl-native python-native"

FILES_${PN} = "${bindir}/node ${bindir}/npm ${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace/node.d"

BBCLASSEXTEND = "native"